HDU 1081 To The Max(最大子矩阵和)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/BBHHTT/article/details/82014220

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15068    Accepted Submission(s): 7031

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

Sample Output

15

最大子矩阵和

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mat[105][105];
int dp[105];
int main()
{
	int n;
	while(~scanf("%d",&n)) {
		int maxn=0;
		for(int i=0;i<n;i++) {
			for(int j=0;j<n;j++) {
				scanf("%d",&mat[i][j]);
			}
		}
		for(int i=0;i<n;i++) {
			for(int j=i;j<n;j++) {
				int sum=0;
				for(int k=0;k<n;k++) {
					dp[k]=(i==j)?mat[i][k]:(dp[k]+mat[j][k]);
					if(sum<0) sum=0;
					sum+=dp[k];
					maxn=max(sum,maxn);
				}
			}
		}
		printf("%d\n",maxn);
	}
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/BBHHTT/article/details/82014220
今日推荐