HDU—1081最大子矩阵和

原题传送

To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14948 Accepted Submission(s): 6983

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output
15

题意:
给出一个N*N的矩阵,求它的最大子矩阵和。

求一个n行m列矩阵的最大子矩阵和,下面给出一个模板。

#include<stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
const int N=507;
typedef long long ll;
ll sum[N][N],mn,ans,x,tot;//ans定义成全局变量,所以其初始值为0 
int i,j,k,n,m;
int main()
{
    scanf("%d%d",&m,&n); //n行m列的矩阵 
    memset(sum,0,sizeof(sum));
    for(i=1;i<=n;++i)
    {
    for(j=1;j<=m;++j)
    {
        scanf("%lld",&sum[i][j]);
    sum[i][j]+=sum[i][j-1];
     }
    }

    for(i=1;i<=m;++i)
    {
        for(j=i;j<=m;++j){
        x=0,mn=0;
        for(k=1;k<=n;++k)
        {
            x+=(sum[k][j]-sum[k][i-1]);
            ans=max(ans,x-mn);
            mn=min(mn,x);
        }
    }
    }
    printf("%lld\n",ans);
}

此题求n行n列矩阵,并且为多组数据,注意 ans 和二维数组的初始化问题即可,其他的套用模板就行。

下面给出AK代码:

#include<stdio.h>
#include<string.h>
#include<algorithm> 
using namespace std;
const int N=507;
typedef long long ll;
ll sum[N][N],mn,ans,x,tot;
int i,j,k,n,m;
int main()
{
    while(~scanf("%d",&m))
{
      for(i=1;i<=m;i++)
      {
        memset(sum[i],0,sizeof(sum[i]));
      } 
      ans=0;//初始化 
    for(i=1;i<=m;++i)
    {
    for(j=1;j<=m;++j)
    {
        scanf("%lld",&sum[i][j]);
    sum[i][j]+=sum[i][j-1];
     }
    }

    for(i=1;i<=m;++i)
    {
        for(j=i;j<=m;++j){
        x=0,mn=0;
        for(k=1;k<=m;++k)
        {
            x+=(sum[k][j]-sum[k][i-1]);
            ans=max(ans,x-mn);
            mn=min(mn,x);
        }
    }
    }
    printf("%lld\n",ans);
}
}

猜你喜欢

转载自blog.csdn.net/qq_42804678/article/details/81428764
今日推荐