To The Max HDU - 1081[最大字段和扩展 -> 最大子矩阵和]

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14265    Accepted Submission(s): 6775


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
 
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
 
  
15
 

Source
 

参考之前的题目吧。。。。。

代码:

#include<bits/stdc++.h>
#define ll long long

using namespace std;
const int maxn = 1e2+7;

int n, m[maxn][maxn], sum[maxn][maxn];

void clomn()
{
    memset(sum, 0, sizeof(sum));
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
           sum[i][j] = sum[i - 1][j] + m[i][j];
}

int solve()
{
    clomn();
    int ans = -10000;
    for(int r1 = 1; r1 <= n; r1++)
        for(int r2 = r1; r2 <= n; r2++)
        {
            int t = 0;
            for(int i = 1; i <= n; i++)
            {
                t += sum[r2][i] - sum[r1 - 1][i];
                ans = max(t, ans);
                if(t < 0) t = 0;
            }
        }
    return ans;
}


int main()
{
    //freopen("in.txt", "r", stdin);
    while(~scanf("%d",&n))
    {
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++) scanf("%d",&m[i][j]);
        printf("%d\n", solve());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_39792252/article/details/80300514
今日推荐