HDU1081 POJ1050 LA2288 To The Max【最大子段和+DP+滑动窗口法】

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 57677 Accepted: 30556

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

扫描二维码关注公众号,回复: 10941104 查看本文章

8 0 -2

Sample Output

15

Source
Greater New York 2001

问题链接HDU1081 POJ1050 LA2288 To The Max
问题简述:(略)
问题分析
    这是一个最大子矩阵和的问题,可以将其转化为计算最大子段和问题,一个经典的动态规划问题。
    一种方法是采用前缀和+滑动窗口法来解决。对于每一行计算前缀和,再按列计算最大子段和。计算最大子段和时,使用滑动窗口法来解决。
    另外一种方法是采用前缀和+DP的方法来解决。对于每一行计算前缀和,再按列计算最大子段和。
    最后一种方法采用穷尽搜索的方法来解决。在列上,通过计算最大子段和来达到计算最大子矩阵的目的。程序中的数组b[]用于计算各行之和,其起始行从0到n-1(穷举法),实际的计算过程是动态的。这个方法似乎有BUG。
    似乎线段树也可以解决最大子矩阵和的问题,参见参考链接。
程序说明:(略)
参考链接hdu1081 DP类最大子段和(二维压缩+前缀和数组/树状数组计数)
题记:(略)

AC的C++语言程序(前缀和+滑动窗口法)如下:

/* HDU1081 POJ1050 LA2288 To The Max */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>

using namespace std;

const int N = 100 + 1;
int sum[N][N];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        // 读入矩阵并对每一行计算前缀和
        for(int i = 1; i <= n; i++) {
            sum[i][0] = 0;
            for(int j = 1; j <= n; j++) {
                scanf("%d", &sum[i][j]);
                sum[i][j] += sum[i][j - 1];
            }
        }

        // 滑动窗口法:按第i-j列,对所有的行计算最大子段和
        int maxSum = INT_MIN;
        for(int i = 1; i <= n; i++)
            for(int j = i; j <= n; j++) {
                int subSum = 0;
                for(int k = 1; k <= n; k++) {
                    subSum += sum[k][j] - sum[k][i - 1];
                    if(subSum > maxSum) maxSum = subSum;
                    if(subSum < 0) subSum = 0;
                }
            }

        printf("%d\n", maxSum);
    }

    return 0;
}

AC的C++语言程序(前缀和+DP)如下:

/* HDU1081 POJ1050 LA2288 To The Max */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>

using namespace std;

const int N = 100 + 1;
int sum[N][N], dp[N];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        // 读入矩阵并对每一行计算前缀和
        for(int i = 1; i <= n; i++) {
            sum[i][0] = 0;
            for(int j = 1; j <= n; j++) {
                scanf("%d", &sum[i][j]);
                sum[i][j] += sum[i][j - 1];
            }
        }

        // 按第i-j列,对所有的行计算最大子段和
        int ans = INT_MIN;
        for(int i = 1; i <= n; i++)
            for(int j = i; j <= n; j++) {
                memset(dp, 0, sizeof(dp));
                for(int k = 1; k <= n; k++) {
                    if(dp[k - 1] > 0)
                        dp[k] = dp[k - 1] + (sum[k][j] - sum[k][i - 1]);
                    else
                        dp[k] = sum[k][j] - sum[k][i - 1];
                    ans = max(ans, dp[k]);
                }
            }

        printf("%d\n", ans);
    }

    return 0;
}

AC的C++语言程序如下:

/* UVALive2288 POJ1050 HDU1081 ZOJ1074 To The Max */
 
#include <iostream>
#include <limits.h>
#include <string.h>
 
using namespace std;
 
const int N = 100;
int a[N][N], b[N];
 
int main()
{
    int n, maxval;
 
    while(cin >> n) {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                cin >> a[i][j];
 
        maxval = INT_MIN;
        for(int i=0; i<n; i++) {
            memset(b, 0, sizeof(b));
 
            for(int j=i; j<n; j++) {
                int sum = 0;
                for(int k=0; k<n; k++) {
                    b[k] += a[j][k];
 
                    if(sum + b[k] > 0)
                        sum += b[k];
                    else
                        sum = b[k];
 
                    maxval = max(maxval, sum);
                }
            }
        }
 
        cout << maxval << endl;
    }
 
    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105444403