hdu 1081 (最大子矩阵和)dp To The Max

Problem Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input

The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output

15
题意:题目不难理解呀。就是给你一个nn的矩阵,让你找出和最大的子矩阵来。
这种题原来做过,好久没看了,忘了。。。。大体的思路就是先将原来矩阵每一行的数存到一个n
n的前缀和数组里。然后控制列数,移动行数,这样来找寻最大子矩阵。有的题解说这样是二维压缩成一维,我也不太明白。反正思路明白就好了。
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;

int a[101][101];
int n;
int temp;

int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&temp);
				a[i][j]=a[i][j-1]+temp;
			}
		}
		int ans=-inf;
		int res=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=i;j<=n;j++)
			{
				for(int k=1,res=0;k<=n;k++)//每次行数从头开始的时候就要将res更新为0
				{
					res+=(a[k][j]-a[k][i-1]);
					if(res<0) res=0;//res小于0时,res就要更新为零!!!
					ans=max(ans,res);
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

努力加油a啊,(o)/~

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/82951265
今日推荐