每日一题之 hdu2844 Coins

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4

思路:

多重背包:
理解了二进制优化的多重背包。这里需要注意的是首先将dp[i]赋值为负无穷大,且令dp[0] = 0,不然容易状态泄露。详情见背包九讲

单调队列优化:单调队列优化

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <set>
using namespace std;

const int maxn = 1e5 + 5;

int A[maxn],C[maxn];
int dp[maxn];
int n,m;

void ZeroOnePack(int cost, int weight)
{
    for (int j = m; j >= cost; --j) {
        dp[j] = max(dp[j], dp[j-cost] + weight);
    }
}

void CompletePack(int cost, int weight)
{
    for (int j = cost; j <= m; ++j) {
        dp[j] = max(dp[j], dp[j-cost] + weight);
    }
}

void MultiPack(int cost, int weight, int amount) 
{
    if (cost * amount >= m) CompletePack(cost, weight);
    else {
        int k = 1;
        while( k < amount) {
            ZeroOnePack(k*cost, k*weight);
            amount -= k;
            k *= 2;
        }
        ZeroOnePack(amount*cost, amount*weight);
    }
}

int main()
{
    while(cin >> n >> m) {
        if (n == 0 || m == 0) return 0;
        memset(A,0,sizeof(A));
        memset(C,0,sizeof(C));
        memset(dp,0,sizeof(dp));
        for (int i = 0; i < n; ++i)
            cin >> A[i];

        for (int j = 0; j < n; ++j)
            cin >> C[j];

        for (int i = 0; i < m; ++i) dp[i] = -maxn*100 ;

        dp[0] = 0;
        for (int i = 0; i < n; ++i)
            MultiPack(A[i],A[i],C[i]);

        int res = 0;
        for (int i = 1; i <= m; ++i)
            if (dp[i] > 0) ++res;

        cout << res << endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/u014046022/article/details/80779049
今日推荐