hdu2844

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18554    Accepted Submission(s): 7299


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
 
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
 
  
8 4
 

Source

2009 Multi-University Training Contest 3 - Host by WHU


多重背包

#include<bits/stdc++.h>
using namespace std;
int m, n;
int v[105],num[105];
int dp[100005];
int main()
{
    while(cin >> n >> m && n && m)
    {
    	fill(dp,dp + 100005, -99999999);
    	dp[0] = 1;  //面值为0的时候只要一种选择  即 不掏钱 
    	for(int i = 1;i <= n;i ++)
    	{
    		cin >> v[i];
		}
		for(int i = 1;i <= n;i ++)
    	{
    		cin >> num[i];
		}
		for(int i = 1;i <= n;i ++)
		{
			//按完全背包算 
			if(num[i] * v[i] >= m)
			{
				for(int j = v[i];j <= m;j ++)
				dp[j] = max(dp[j], dp[j - v[i]] + v[i]);
			}
			else
			{
				for(int j = 1;j <= num[i];j = j*2)
				{
					for(int k = m;k >= v[i] * j;k --)
					{
						dp[k] = max(dp[k], dp[k - v[i] * j] + v[i] * j);
					}
					num[i] -= j;
				}
				
				if(num[i] > 0)
				{
					for(int j = m;j >= v[i] * num[i];j --)
					dp[j] = max(dp[j], dp[j - v[i] * num[i]] + v[i] * num[i]);
				}
			}
		}
		
		int cnt = 0;
		for(int i = 1;i <= m;i ++)
		{
			if(dp[i] > 0)   //i表示面值  如果说面值为i时的值不为0  则 说明此时有组成i的解 
			cnt ++;
		}
		
		cout << cnt << endl; 
		
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80275004