HDOJ--1005Number Sequence

原题链接




Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
  
1 1 3 1 2 10 0 0 0
 

Sample Output
 
  
2 5
 

思路:因为对7求余,每种变量只有7种可能性,题目有两个变量,就有7*7=49种可能性

代码

#include<stdio.h>
int main()
{
	int fn[51]={1,1,1};
	int A,B,N;
	int i,n;
	while(scanf("%d%d%d",&A,&B,&N)&&(A|B|N))
	{
		for(i=3;i<=N%49;i++)
		{
			fn[i]=((A*fn[i-1])+(B*fn[i-2]))%7;
		}
		printf("%d\n",fn[N%49]);
	}
	return 0;
}


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
   
1 1 3 1 2 10 0 0 0
 

Sample Output
 
   
2 5
 

猜你喜欢

转载自blog.csdn.net/y_cnew/article/details/79836211
今日推荐