PAT甲级 1007. Maximum Subsequence Sum(25分) 复杂度优化到O(n)

1007. Maximum Subsequence Sum(25分)

Given a sequence of K integers { N1, N2, …, N**K }. A continuous subsequence is defined to be { N**i, N**i+1, …, N**j } where 1≤ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

结尾无空行

Sample Output:

10 1 4

结尾无空行
#include <iostream>
using namespace std;

int main()
{
    
    
    int N;
    cin >> N;
    int A[N];
    for (int i = 0; i < N; i++)
    {
    
    
        cin >> A[i];
    }
    // 最大子序列和:在线处理,直接累加,如果累加到当前的和为负数,置当前值或0 时间复杂度N
    int sum = 0, maxsum = -1, start = 0, end = N - 1, index = 0;
    for (int i = 0; i < N; i++)
    {
    
    
        sum += A[i];
        if (sum < 0)
        {
    
    
            index = i + 1;
            sum = 0;
        }
        else if (sum > maxsum)
        {
    
    
            maxsum = sum;
            start = index;
            end = i;
        }
    }
    if (maxsum < 0)
    {
    
    
        maxsum = 0;
    }
    cout << maxsum << " " << A[start] << " " << A[end];
    return 0;
}

时间复杂度: O ( n ) O(n) O(n),直接一遍遍历,更新最大值,如果 s u m < 0 sum<0 sum<0,说明前面这段对我的子序列来说,只会产生负反馈,所以直接剔除。

卡壳的主要原因是英文水平不行,又或者说没有仔细阅读题目。together with the first and the last numbers of the maximum subsequence,好好看看它的意思,求的是元素而不是索引。

猜你喜欢

转载自blog.csdn.net/leoabcd12/article/details/119548354
今日推荐