pat甲级1007. Maximum Subsequence Sum (25)

原题链接:https://www.patest.cn/contests/pat-a-practise/1007

欢迎访问我的pat甲级题解目录哦https://blog.csdn.net/richenyunqi/article/details/79958195

1007. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

算法设计:

这是一道动态规划的题目,如果将以A[i]结尾的最大子序列和存储在dp[i]中的话,那么dp[i]=max(dp[i-1]+A[i],A[i]),利用这个状态转移方程即可求出结果。

注意点:

题目要求输出首尾数字,而不是首尾数字所在的位置索引。

c++代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int N,maxIndex=0;//maxIndex存储最大子序列末尾数字所在索引
    scanf("%d",&N);
    int A[N];
    for(int i=0;i<N;++i)
        scanf("%d",&A[i]);
    pair<int,int>dp[N]={{A[0],0}};//first元素存储子序列和,second元素存储子序列起始位置
    for(int i=1;i<N;++i){
        if(A[i]<=dp[i-1].first+A[i])
            dp[i]={dp[i-1].first+A[i],dp[i-1].second};
        else
            dp[i]={A[i],i};
        if(dp[i].first>dp[maxIndex].first)//更新最大子序列末尾数字所在索引
            maxIndex=i;
    }
    if(dp[maxIndex].first<0)//如果最大子序列和<0,说明都是负数
        printf("0 %d %d",A[0],A[N-1]);
    else
        printf("%d %d %d",dp[maxIndex].first,A[dp[maxIndex].second],A[maxIndex]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/richenyunqi/article/details/80216843