[PAT 甲级] 1007 Maximum Subsequence Sum (25 分)【动态规划】

版权声明:原创博客,转载请标明出处! https://blog.csdn.net/caipengbenren/article/details/88928876

1007 Maximum Subsequence Sum (25 分)

原题链接
Given a sequence of K integers { N
​​ }. A continuous subsequence is defined to be { N
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4


动态规划方程:
dp[i] = dp[i - 1] + val[i] ;pre[i] = pre[i - 1] 当dp[i - 1] > 0 && dp[i - 1] + val[i] > 0
dp[i] = val[i]; pre[i] = i 当 dp[i - 1] <= 0 && val[i] > 0


但是第5个测试数据一直没过。如果你可以看出的我的错误,望赐教。
在这里插入图片描述


#include<iostream>
using namespace std;
int val[10001];
int dp[10001];
int pre[10001];
int main () {
    int n;
    cin >> n;
    for (int i = 1; i <= n; i ++) {
        cin >> val[i];
    }
    int sum_max = 0;
    int a = 0, b = 0;
    for (int i = 1; i <= n; i++) {
        if (dp[i - 1] > 0 && dp[i - 1] + val[i] > 0) { //如果i前面的序列是大于0的 那么就考虑加入i
                dp[i] = dp[i - 1] + val[i];
                pre[i] = pre[i - 1];
            
        } else if (dp[i - 1] <= 0 && val[i] > 0){
                dp[i] = val[i];
                pre[i] = i;
        }
        if (dp[i] > sum_max) {
            a = val[pre[i]];
            b = val[i];
            sum_max = dp[i];
        }
    }
    cout << sum_max << " ";
    if (sum_max == 0) {
        cout << val[1] << " " << val[n];
    } else {
        cout << a << " " << b;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/caipengbenren/article/details/88928876