PAT 1007. Maximum Subsequence Sum (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_34621169/article/details/51484600

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4
求连续的几个数字相加的最大的值,以及他们的坐标
 
 
 
 
遍历两边的AC代码:
#include <iostream>
#include <algorithm>
#include <fstream>
#include <cstdlib>
#include <string>
#include <iomanip>
#include <sstream>
#include <cstring>
#include <stack>
using namespace std;
int main(){
    int a[10008];
    int n, sum = -1, tmp, start, end;
    cin>>n;
    for (int i = 0; i < n; i++)
        cin>>a[i];
    for (int i = 0; i < n; i++){
        tmp = 0;
        for (int j = i; j < n; j++){
            tmp += a[j];
            if (tmp > sum){
                sum = tmp;
                start = a[i];
                end = a[j];
            }
        }
    }
    if (sum < 0){
        cout<<"0"<<" "<<a[0]<<" "<<a[n-1]<<endl;
        return 0;
    }
    cout<<sum<<" "<<start<<" "<<end<<endl;
    return 0;
}
 
 
百度的大神的遍历一遍就AC的代码:
#include <cstdio>  
int a[10001];  
int main(){  
    int k;  
    scanf("%d", &k);  
    for (int i = 0; i < k; i++){  
        scanf("%d", &a[i]);  
    }  
    int sum = 0, start = 0, end = k - 1, temp = 0, tempi = 0, tempj = 0;  
    for (int i = 0; i < k; i++){  
        if (temp >= 0){  
            temp += a[i];  
            tempj = i;  
        }  
        else{  
            temp = a[i];  
            tempi = i;  
            tempj = i;  
        }  
        if (temp > sum || (temp == 0 && end == k -1)){  
            sum = temp;  
            start = tempi;  
            end = tempj;  
        }  
    }  
    printf("%d %d %d\n", sum, a[start], a[end]);  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/qq_34621169/article/details/51484600