PAT 1007 Maximum Subsequence Sum (25 分)

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N 1 , N 2 , . . . , N K N​_1, N_​2, ..., N_K }. A continuous subsequence is defined to be { N i , N i + 1 , . . . , N j N_i, N_{​i+1}, ..., N_{j} } where 1 i j K 1≤i≤j≤K . The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K ( 10000 ≤10000 ). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4




解析

我真是又菜又笨。(ノへ ̄、)。树,图都不熟。DP什么的还没学。难受




看过网易云课堂上的浙江大学数据结构(陈悦&何钦铭)。或看过数据结构与算法分析-C语言描述的。一定都对这题记忆深刻。
这题用在线处理算法解决。不懂的可以去听听陈悦姥姥的讲解。
但其实就是DP。




Code

#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
int main()
{
	int N;
	cin >> N;
	int min_i = 0, max_i = N - 1, temp_i = 0, maxsum = -1, thissum = 0;
	vector<int> data(N, 0);
	for (int i = 0; i < N; i++)
		cin >> data[i];
	for (int i = 0; i < N; i++) {
		thissum += data[i];
		if (thissum < 0) {
			thissum = 0;
			temp_i = i + 1;
		}
		else if (thissum > maxsum) {
			maxsum = thissum;
			max_i = i;
			min_i = temp_i;
		}
	}
	maxsum = (maxsum == -1) ? 0 : maxsum;
	cout << maxsum << " " << data[min_i] << " " << data[max_i];
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82793698