[PAT甲级]1007. Maximum Subsequence Sum(求连续最大子序列和)

1007. Maximum Subsequence Sum

原题链接

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:

  • 给一个数组,数组长度k<=10000,找出和最大的连续子序列
  • 输出该子序列和,开始元素,结束元素
  • 若数组全是负数,定义和为0,同时输出数组第一个元素和最后一个元素

思路:

  • sum 最大连续子序列和
  • tempsum 临时的连续子序列和
  • left 最大子序列左下标
  • right 最大子序列右下标
  • index 临时的序列左下标
  • tempsum += arr[i],当tempsum >sum,就更新sum的值、left和right的值;当tempsum小于sum且小于0时,舍弃前面的序列,重新定义tempsum和index

代码:

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;

int main()
{
    int n;
    cin >> n;
    vector<int> arr(n);
    int sum=-1;//最大连续子序列和
    int tempsum=0;//临时的连续子序列和
    int left=0;//最大子序列左下标
    int right=0;//最大子序列右下标
    int index=0;//临时的序列左下标
    bool flag = true;//检验是否全是负数
    for(int i=0; i<n; i++){
        scanf("%d", &arr[i]);
        if(arr[i] >= 0)
            flag = false;
        tempsum += arr[i];
        if(tempsum > sum){
            sum = tempsum;
            left = index;
            right = i;
        }else if(tempsum < 0){//如果临时序列和已经小于sum的情况下还是负数,应该舍弃之前的序列
            index = i+1;
            tempsum = 0;
        }
    }
    if(flag){
        printf("0 %d %d", arr[0], arr[n-1]);
    }else{
        printf("%d %d %d", sum, arr[left], arr[right]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/whl_program/article/details/77431896