PAT甲级真题(动态规划)——1007 Maximum Subsequence Sum (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/85715287

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1, N​2 , …, NK }. A continuous subsequence is defined to be { N​i, N​i+1, …, N​j} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:

求最大连续子序列的和,以及开始数字和结束数字。特殊情况为全为负值,做特殊处理。

题目解析:

maxsum,max_begin,max_end分别为要求的最大和,开始数字和结束数字,用sum保存临时最大值,通过二重循环计算出所有的情况,按要求更新数据。

具体代码:

#include<iostream>
#include<vector>
using namespace std;


int main()
{
    int n,sum,maxsum=-1,max_begin,max_end;
    bool flag=false;
    cin>>n;
    int v[10001];
    for(int i=1;i<=n;i++){
    	cin>>v[i];
    	if(v[i]>=0)
    		flag=true;
	}
	if(flag==false){
		cout<<0<<" "<<v[1]<<" "<<v[n];
		return 0;
	}
	for(int i=1;i<=n;i++){
		sum=0;
		for(int j=i;j<=n;j++){
			sum+=v[j];
			if(sum>maxsum){
				maxsum=sum;
				max_begin=i;
				max_end=j;
			}
		}
	}
	cout<<maxsum<<" "<<v[max_begin]<<" "<<v[max_end];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/85715287