PAT (Advanced Level) 1007 Maximum Subsequence Sum (25 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/83793696

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Code

#include <iostream>
#include <vector>

using namespace std;

int main()
{
	int n;
	cin >> n;
	vector<int> v(n);
	int leftIndex = 0, rightIndex = n - 1, sum = -1, temp = 0, tempIndex = 0;
	for (int i = 0; i < n; i++) {
		cin >> v[i];
		temp += v[i];
		if (temp < 0) {
			temp = 0;
			tempIndex = i + 1;
		}
		else if (temp > sum) {
			sum = temp;
			leftIndex = tempindex;
			rightIndex = i;
		}
	}
	if (sum < 0) sum = 0;
	cout << sum << " " << v[leftIndex] << " " << v[rightIndex] << endl;
	return 0;
}

思路

用vector v(n)保存所有输入的数,要输出的最大字串和保存在sum中,leftindex、rightindex分别保存其左端点和右端点,temp为当前字串和,tempIndex为temp的左端点。从左到右扫描v(n),temp为累加和,当扫描到第i个数时,如果temp += v[i]后,temp为负,那么temp置为0,tempIndex置为i+1,因为temp+v[i+1] < v[i+1];如果temp > sum那么更新sum的值和左右端点。
本文代码参考https://blog.csdn.net/liuchuo/article/details/52144554感谢这位博主的分享!
以上

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/83793696
今日推荐