PAT (Advanced Level) 1007. Maximum Subsequence Sum (25) dp

题目链接

1007. Maximum Subsequence Sum (25)

Time limit:400 ms Memory limit:65536 kB


Problem Descrpition

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output

10 1 4

题意

求最大子段和,输出第一个数和最后一个,如果有多个,则输出序号最小的,对于全为负的输出0

解题思路

就一个点想了好久。。。对于

3
-1 0 -2

这组数据应该输出0 0 0

Code

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <map>
#include <string>
using namespace std;

typedef long long LL;
#define INF 0x3f3f3f3f3f3f3f3f
const int maxn=10000+5;

LL a[maxn],dp[maxn];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>a[i];
        dp[i]=a[i];
        //cout<<dp[i]<<' ';
    }
    LL sum=0,st=1,ed=1,ans=-1,ansst=0,ansed=0;
    for(int i=1;i<=n;i++)
    {
        if(dp[i-1]>0)
        {
            dp[i]=dp[i-1]+a[i];
            ed++;
        }
        else
        {
            dp[i]=a[i];
            st=i,ed=i;
        }
       // cout<<dp[i]<<' '<<ans<<endl;
        if(dp[i]>ans)
        {
            ansst=st,ansed=ed;
            ans=dp[i];
        }
    }
    if(ans==-1)
    {
        ans=0;
        ansst=1,ansed=n;
    }
    cout<<ans<<' '<<a[ansst]<<' '<<a[ansed]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xp731574722/article/details/79547656