1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

动态规划问题,要有一个暂时sum,一旦暂时sum大于目前最大值就更新参数,而当这个sum<0时,就要放弃这个起始位置。从下一个位置开始。

#include <iostream>
#include <string>
using namespace std;
int main() {
    int n, a[10008], sum=0,xsum=-1, f=0,xf=0;
    cin >> n;
    int e = n - 1;
    for (int i = 0; i < n; i++) {
        cin >> a[i];
        sum += a[i];
        if (sum < 0) {
            f = i + 1; sum = 0;
        }
        else if (sum > xsum) {
            xsum = sum;
            xf = f;
            e = i;
        }
    }
    if (xsum < 0)xsum = 0;
    cout << xsum << " " << a[xf] << " " << a[e];
    }

猜你喜欢

转载自blog.csdn.net/sc_jn/article/details/79835911