Java 实现合根植物 并查集

问题描述
  w星球的一个种植园,被分成 m * n 个小格子(东西方向m行,南北方向n列)。每个格子里种了一株合根植物。
  这种植物有个特点,它的根可能会沿着南北或东西方向伸展,从而与另一个格子的植物合成为一体。

如果我们告诉你哪些小格子间出现了连根现象,你能说出这个园中一共有多少株合根植物吗?
输入格式
  第一行,两个整数m,n,用空格分开,表示格子的行数、列数(1<m,n<1000)。
  接下来一行,一个整数k,表示下面还有k行数据(0<k<100000)
  接下来k行,第行两个整数a,b,表示编号为a的小格子和编号为b的小格子合根了。

格子的编号一行一行,从上到下,从左到右编号。
  比如:5 * 4 的小格子,编号:
  1 2 3 4
  5 6 7 8
  9 10 11 12
  13 14 15 16
  17 18 19 20

样例输入
5 4
16
2 3
1 5
5 9
4 8
7 8
9 10
10 11
11 12
10 14
12 16
14 18
17 18
15 19
19 20
9 13
13 17

样例输出
5

import java.util.HashSet;
import java.util.Scanner;

public class RootePlant{
	static int[] pre;
	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		int m=scanner.nextInt();
		int n=scanner.nextInt();
		int k=scanner.nextInt();
		pre=new int[m*n+1];
		for(int i=1;i<=m*n;i++) {
			pre[i]=i;
		}
		for(int i=0;i<k;i++) {
			int a=scanner.nextInt();
			int b=scanner.nextInt();
			union(a,b);
		}
		HashSet<Integer> set=new HashSet<Integer>();
		for(int i=1;i<=m*n;i++) {
			set.add(find(i));
		}
		System.out.println(set.size());
	}
	public static int find(int x) {
		int x_root=x;
		while(pre[x_root]!=x_root) {
			x_root=pre[x_root];
		}
		return x_root;
	}
	public static void union(int x,int y) {
		int x_root=find(x);
		int y_root=find(y);
		if(x_root!=y_root) {
			pre[y_root]=x;
		}
	}
}

在这里插入图片描述

发布了39 篇原创文章 · 获赞 19 · 访问量 1494

猜你喜欢

转载自blog.csdn.net/weixin_44222272/article/details/104524250