HDU-1024 Max Sum Plus Plus (DP m子段的最大和)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89392421

Max Sum Plus Plus

 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1024

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8


        
  

Hint

Huge input, scanf and dynamic programming is recommended.

        

题目大意:给出m,n,和长度为n的数列,要求出其中m个子段和的最大值

思路:

扫描二维码关注公众号,回复: 5942739 查看本文章

dp [ i ] [ j ] 为前 j 个数分成 i 组的最大和

状态转移方程:dp[ i ] [ j ]=max (dp [ i ] [ j-1 ] + a[ j ] , dp [ i-1 ] [ j-1 ] + a[ j ]) ;

dp [ i ] [ j-1 ] + a[ j ] 表示前 j-1个数分成 i 组的最大和加 a [ j ] ,就是把第j个数放在前一组里

 dp [ i-1 ] [ j-1 ] + a[ j ] 表示前 j-1个数分成 i -1 组,第 j 个数为单独的一组

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1000005;
const int inf=0x3f3f3f;
int a[N],dp[N],ma[N];
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        memset(ma,0,sizeof(ma));
        int maxx;
        for(int i=1;i<=m;i++)//分成i组
        {
            maxx=-inf; //记录分成i组的最大和
            for(int j=i;j<=n;j++) //前j个数分成i组,至少需要i个数
            {
                //dp记录前j个数分成i组的最大值,ma[j-1]为前j-1个数分成i-1组的最大和
                dp[j]=max(dp[j-1]+a[j],ma[j-1]+a[j]);
                ma[j-1]=maxx;//更新前j-1个数分成i组的最大和
                maxx=max(maxx,dp[j]);
            }
        }
        printf("%d\n",maxx);//最后的maxx记录的就是n个数分成m组的最大和
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89392421