优先队列——POJ 2431 Expedition

Expedition

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P
    Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
    Sample Input

4
4 4
5 2
11 5
15 10
25 10
Sample Output

2

#include<cstdio>
#include<iostream>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<functional>
using namespace std;
typedef unsigned long long ll;

int n,L,P;
struct node{
    int l,p;
}a[10005];

bool cmp(node a,node b){
    return a.l < b.l;
}
void op(){
    priority_queue<int>q; //默认从大到小,只需要存这一点往前的油量排序
    a[n].l = L;
    a[n].p = P;
    n++;
    int pos = 0,cnt = 0;
    for(int i=0; i<n; i++){
        int t = a[i].l - pos;
        while(P-t<0){           //到不了,检查队列
            if(q.empty()){
                cout << "-1" << endl;
                return ;
            }
            else{
                P += q.top();
                q.pop();
                cnt++;
            }
        }
        P -= t;             //到的了:先不加油,把油的数据放到队列
        pos = a[i].l;
        q.push(a[i].p);
    }
    cout << cnt << endl;
}
int main(){
    
    while(cin >> n){
        for(int i=0; i<n; i++){
            cin >> a[i].l >> a[i].p;
        }
        cin >> L >> P;
        for(int i=0; i<n; i++){
            a[i].l = L - a[i].l;
        }
        sort(a,a+n,cmp); //距离起点从小到大排序
        op();
    }
    return 0;
}
//注意:给出的点的位置是离加油站的,也就是一开始是远的
//思路:从近到远,如果距离大于目前的油
//那么看队列里是否有之前经过的点,没有-1 有:挑一个最大的加上
//将油放入

发布了30 篇原创文章 · 获赞 0 · 访问量 671

猜你喜欢

转载自blog.csdn.net/jhckii/article/details/104176198
今日推荐