Expedition//POJ - 2431//优先队列

Expedition//POJ - 2431//优先队列


题目

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

  • Line N+2: Two space-separated integers, L and P
    Output

  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
    Sample Input
    4
    4 4
    5 2
    11 5
    15 10
    25 10
    Sample Output
    2
    题意
    给出距离,加油站个数以及每个加油站的距离和油量,给出车现在的距离和现有油量,求最少加多少次油。
    链接:https://vjudge.net/contest/352439#problem/F

思路

贪心+优先队列,找有最大油量的加油站加。

代码

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long ll;
struct node{
    int dis,fuel;
};
node stop[10001];
bool cmp(node x,node y){
   return x.dis>y.dis;
}
int main()
{
    int n,l,p;
    int ans=0,cnt=0,temp;
    while(scanf("%d",&n)!=EOF){
        priority_queue<int>q;
        for(int i=0;i<n;i++)
            scanf("%d%d",&stop[i].dis,&stop[i].fuel);
        scanf("%d%d",&l,&p);
        sort(stop,stop+n,cmp);
        q.push(p);
        while(l>0 && !q.empty()){
            ans++;
            temp=q.top();
            q.pop();
            l-=temp;
            while(cnt<n && l<=stop[cnt].dis)
                q.push(stop[cnt++].fuel);
        }
        if(l>0)
            printf("-1\n");
        else
            printf("%d\n",ans-1);
    }
    return 0;
}

注意

发布了50 篇原创文章 · 获赞 19 · 访问量 2581

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104259442