Expedition - poj2431 - 优先队列

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22727   Accepted: 6443

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold

思路:

输入的距离是到终点的距离,把它改成带起点的距离后,按距离起点由近到远排序。

我们可以这样想“在到达加油站时,就获得了一次在之后任何时候都可以加油的机会”

因为希望到达终点的加油次数尽可能少,所以当燃料为0时加,选择加油量最大的加,可以用优先队列

在经过加油站i时,往优先队列中加入add[i]

当燃料空的时候:

1、如果队列也空,则无法到达终点

2、取出队列中最大的元素进行加油,直到能到达下一个加油站

代码如下:

我们可以把终点看成是一个加0unit油的加油站

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

int L,P;
struct A{
	int dis,add;
}qq[10005];

bool cmp(A a,A b){
	if(a.dis==b.dis)return a.add>b.add;
	return a.dis<b.dis;
}
int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d%d",&qq[i].dis,&qq[i].add);
	}
	scanf("%d%d",&L,&P);
	for(int i=0;i<n;i++){
		qq[i].dis=L-qq[i].dis;
	}
	sort(qq,qq+n,cmp);
	priority_queue<int> que;
	
	int ans=0,tank=P,pos=0;
	qq[n].add=0;
	qq[n].dis=L;
	for(int i=0;i<=n;i++){
		int d=qq[i].dis-pos;//接下来要前进的距离
		while(tank-d<0){
			if(que.empty()){
				printf("-1\n");
				return 0;
			}
			tank+=que.top();
			que.pop();
			ans++;
		} 
		tank-=d;
		pos=qq[i].dis;
		que.push(qq[i].add);
	}
	printf("%d\n",ans);
}

若单独考虑能不能到终点还有判断一下最后一个加油站的情况

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

int L,P;
struct A{
	int dis,add;
}qq[10005];

bool cmp(A a,A b){
	if(a.dis==b.dis)return a.add>b.add;
	return a.dis<b.dis;
}
int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d%d",&qq[i].dis,&qq[i].add);
	}
	scanf("%d%d",&L,&P);
	for(int i=0;i<n;i++){
		qq[i].dis=L-qq[i].dis;
	}
	sort(qq,qq+n,cmp);
	priority_queue<int> que;
	
	int ans=0,tank=P,pos=0;
	
	for(int i=0;i<n;i++){
		int d=qq[i].dis-pos;//接下来要前进的距离
		//printf("d=%d\n",d);
		while(tank-d<0){
			if(que.empty()){
				printf("-1\n");
				return 0;
			}
			
			tank+=que.top();
			que.pop();
			ans++;
		} 
		tank-=d;
		pos=qq[i].dis;
		que.push(qq[i].add);
	}
	int d=L-pos;
	if(tank>=d)printf("%d\n",ans);
	else {
		while(tank-d<0){
			if(que.empty()){
				printf("-1\n");
				return 0;
			}
			tank+=que.top();
			que.pop();
			ans++;
		}
		printf("%d\n",ans);
	}
}


猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/81346969