POJ 2431-Expedition (优先队列+贪心)

Expedition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21498   Accepted: 6137

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2


一、原题地址

传送门

二、大致题意

    有N个点,每个点给出距离终点的大小和能在这个点获得油量的大小,行驶和油量的消耗是1比1的。尽量减少在途中加油的次数。最后一行给出的是初始的距离和油量。询问最少的加油次数。

三、思路

    模拟当前所在的位置,将一路上可以加油的点全部纳入一个集合Q中。那么我们每次油量不够而需要加油的时候,我们只需要从Q中取出一个最大的油量,即表示我们在那个点加油,我们不需要知道具体加油的点所在的位置的,只需要知道这个点曾在途中遇到过就行。

    这样我们可以用优先队列表示集合Q,将最大的油量置于队列顶,每次取用后ans++即可。

四、代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
#include<map>
#include<stack>
using namespace std;
const int inf = 0x3f3f3f3f;
#define LL long long int 
long long  gcd(long long  a, long long  b) { return a == 0 ? b : gcd(b % a, a); }


int n;
struct Node
{
	int s, v;
}a[10005];
bool cmp(Node xx, Node yy)
{
	return xx.s < yy.s;
}
int D, L;
int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%d%d", &a[i].s, &a[i].v);
	sort(a, a + n, cmp);
	scanf("%d%d", &D, &L);
	priority_queue<int>q;
	int now = n - 1;
	int ans = 0;
	while (D - L > 0)
	{
		for (int i = now; i >= 0; i--)
		{
			if (a[i].s < D - L)
			{
				now = i;
				break;
			}
			else
			{
				q.push(a[i].v);
			}
		}
		D -= L;
		L = 0;
		if (q.empty() && D > 0)
		{
			ans = -1;
			break;
		}
		L += q.top();
		q.pop();
		ans++;
	}
	cout << ans << endl;
	getchar();
	getchar();
}

猜你喜欢

转载自blog.csdn.net/amovement/article/details/80462811