POJ-2431 Expedition(优先队列)

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23135   Accepted: 6549

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

这道题的整体思路是

如果经过某个加油站,则将在该加油站的燃料加入优先队列。先不考虑暂停,当它燃料为0时,每出队一次元素,则暂停次数加一

#include <iostream>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int di;
    int fuel;
};
bool com(node &a,node &b)
{
    return a.di>b.di;
}
int main()
{
    node a[10005];
    int n;
     int L,P;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>a[i].di>>a[i].fuel;
    }
    sort(a,a+n,com);
    cin>>L>>P;
    priority_queue<int>p;
    p.push(P);
    int ans=0,k=0;
    while(L>0&&!p.empty())
    {
        int nx=p.top();
        p.pop();
        L-=nx;
        ans++;
        while(k<n&&L<=a[k].di)/*当燃料用完时,将经过加油站的燃料加入优先队列;
        L很小时(能够使用的燃料很多),可以经过好几个加油站。
            当供给的燃料很少时,L变化很小,无法经过下一个加油站,
            无法向队列里加入燃料,不执行循环。最终队列会为空,无法到达终点。*/
        {
            p.push(a[k++].fuel);
        }
    }
    if(L<=0)
        cout<<ans-1<<endl;
    else
        cout<<"-1"<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wjc1761659069/article/details/81633071
今日推荐