POJ 2431 Expedition 贪心算法+优先队列

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题意:

求最小的加油次数。

思路:

可以用贪心加上优先队列来做, 类似于下列的这个过程:

先让车将车中的油耗完, 途中经过加油站就将它加到优先队列里去, 然后当车没有油时, 再从优先队列里取出元素。 当队列为空且没到终点时, 说明不能到达终点输出-1, 反之则能, 并且求出的就是最小值。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
const int maxn=10005;
int n;
struct city
{
    int dis;
    int fuel;
};
city c[maxn];
int dest,rest;
int compare (const void *a,const void *b)
{
    city * pa=(city *)a;
    city * pb=(city *)b;
    if(pa->dis>pb->dis)
        return 1;
    else
        return -1;
}
int main()
{
    scanf("%d",&n);
    for (int i=0;i<n;i++)
    {
        scanf("%d%d",&c[i].dis,&c[i].fuel);
    }
    scanf("%d%d",&dest,&rest);
    for (int i=0;i<n;i++)
        {
            c[i].dis=dest-c[i].dis;
            //printf("%d ",c[i].dis);
        }
    qsort (c,n,sizeof(c[0]),compare);
    priority_queue<int>q;
    int num=0;
    int flag=0,flag1=0;
    for (int i=0;i<n;i++)
    {
        if(rest>c[i].dis)
            q.push(c[i].fuel);
        else
        {
            int flagg=0;
            while (rest<=c[i].dis)
            {
                if(rest==c[i].dis)
                {
                    q.push(c[i].fuel);
                    flagg=1;
                }
                if(q.empty())
                {
                    printf("-1\n");
                    flag=1;
                    break;
                }
                else
                {
                    rest+=q.top();
                    //printf("%d\n",rest);
                    q.pop();
                    num++;
                    //printf("%d\n",num);
                }
            }
            if(!flagg)
            q.push(c[i].fuel);
        }
        if(flag)
            {
                flag1=1;
                break;
            }
        if(rest>=dest)
        {
            printf("%d\n",num);
            flag1=1;
            break;
        }
    }
    if(!flag1)
    {
        while (!q.empty()&&rest<dest)
        {
            rest+=q.top();
            q.pop();
            num++;
        }
        if(rest>=dest)
            printf("%d\n",num);
        else
            printf("-1\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81517536