D - Expedition POJ - 2431

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

-------------------------------------------------------------------------------------

题意就是一辆车,离城市l的距离,目前车上有p的汽油,开车会消耗汽油,一路上有n个汽油车站,问最少在几个加油站加油,不能到城市就输出-1;

------------------------------------------------------------------------------------

一道贪心题,把车站按离城市远近排序。如果能到这个车站,就把这个车站加入队列中。如果不能到这个车站,说明中途油不够,那就从队列中找一个到过的油站加油,因为要经过最少的油站,所以要找队列中储油量最大的车站,所以这里应该用优先队列。一个小细节,有可能中间某两个车站特别远,要从队列中取出好几个油站,wa了两次。

-------------------------------------------------------------------------------------

#include<deque>
#include<queue>  
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<map>
#include<stack>
const int inf = 0x3f3f3f3f;
using namespace std;
struct node
{
    int stop,val;
    bool operator < (const node & a)const
    {
        return val<a.val;    
    }//结构体重载
}a[10010];

bool cmp(node a,node b)
{
    return a.stop<b.stop;
}

int main()
{
    int n,ans=0,l,p;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&a[i].stop,&a[i].val);
        scanf("%d%d",&l,&p);
        for(int i=1;i<=n;i++)
            a[i].stop=l-a[i].stop;
        a[0].stop=0;//初始位置应该是0
        a[n+1].stop=l;//最后一个车站应该是距离l
        sort(a,a+n+1,cmp);
        priority_queue <node> q;
        for(int i=1;i<=n+1;i++)
        {
            int t;
            t=a[i].stop-a[i-1].stop;
            while(t>p)
            {
                if(q.empty())
                {
                    printf("-1\n");
                    goto end;
                }
                p+=q.top().val;
                q.pop();
                ans++;
            }
            p-=t;
            q.push(a[i]);
        }
        printf("%d\n",ans);
    end:;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41539869/article/details/81075632