POJ - 2431 Expedition (优先队列)

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22528   Accepted: 6390

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold

题意:车有p单位油,要走l长的路,路上有加油站,怎么样使用最少的加油站达到重点;达不到输出 -1;

因为优先队列可以以从大到以的顺序取出,所以用优先队列;

在油料空了时,选择路上油量最多的加油站加油就行了;

模拟过程:

经过加油站时,往优先队列里加入加油站油量;

当燃料空了时时:

如果优先队列也是空的,无法到达终点,

否则取出优先队列中的最大元素,给车加油;

白书: 76页(挑战程序设计竞赛)

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
using namespace std;
typedef long long ll;

const int maxn = 10010;
struct id{
    int x,y;
}dis[maxn];

bool cmp(id a,id b){
    return a.x>b.x;//x是离终点的距离,所以要从大到小排
}

int main()
{
    int n,l,p;
    cin >> n;
    for(int i = 0;i < n;i++)
        cin >> dis[i].x >> dis[i].y;
    //dis[i].x是离终点的距离,后面算离起点距离,要用l-dis[i].x 
    sort(dis,dis+n,cmp);
    cin >> l >> p;
    priority_queue <int> que;
    //维护加油站的优先队列
    dis[n].x = 0,dis[n].y=0,n++;
    //为了排序方便,我们认为终点也是加油站
    int pos = 0,tank = p,ans = 0;
    //ans:加油数量,pos:当前位置;tank:当前油量
    for(int i = 0;i < n;i++){
        int d = (l-dis[i].x) - pos;
        //接下去要前进的距离
        while(tank - d < 0){//不断加油直到油量足够行驶到下一个加油站
            if(que.empty()){
                puts("-1");
                return 0;
            }
            tank += que.top();
            que.pop();
            ans++;
        }
        tank -= d;
        pos = l-dis[i].x;
        que.push(dis[i].y);
    }
    cout << ans << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81254490