POJ - 2431 Expedition (贪心 + 优先队列 + 思维)

Expedition

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题意:给定一个L,P . L 代表当前距目的地的距离,P 代表其实油量,然后有 n 个加油站,给出每个加油站与终点的距离,和此加油站提供的油量,问最后至少加几次油能够到达目的地,如果不能到达输出 -1;

思路:对于每一个已经路过的加油站,我们可以把它所提供的油量存起来,在油不够的时候再提取,而每次提取都是提取最大的,这样就能保证所用的加油的次数最少。! ! ! ! 还要一点值得注意的,给出的是加油站的信息,所以最后需要加入终点,把终点视为一个加油站(因为这个WA了无数发),我的代码每一次都是保证是否能够到达当前位置的加油站。

AC代码:

#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define INT(t) int t; scanf("%d",&t)
#define LLI(t) LL t; scanf("%I64d",&t)

using namespace std;

const int maxn = 1e4 + 10;

struct xx {
    int a, b;
} node[maxn];

bool cmp(xx A, xx B) {
    return A.a > B.a;
}

int main() {
    int n;
    while(~scanf("%d", &n)) {
        rep(i, 0, n) scanf("%d%d", &node[i].a, &node[i].b);
        sort(node, node + n, cmp);
        int L, P;
        scanf("%d%d", &L, &P);
        priority_queue<int> Q;
        int flag = 1, coun = 0;
        node[n].a = 0; node[n].b = 0;
        rep(i, 0, n + 1) {
            P -= L - node[i].a;
            L = node[i].a;
            if(P >= 0){
                Q.push(node[i].b);
                continue;
            }
            while(P < 0 && !Q.empty()){
                ++ coun;
                P += Q.top();
                Q.pop();
            }
            if(P < 0){ flag = 0; break; }
            else Q.push(node[i].b);
        }
        if(!flag)
            printf("-1\n");
        else
            printf("%d\n", coun);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_O_ac/article/details/82888053