1134 Vertex Cover (25 分)(vector+暴力模拟)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

vertex cover
点覆盖

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e4+5;
bool vis[N];
vector<int> v[N];
void judge(int m){
     for(int i=1;i<=m;i++){
	 if(!vis[i]){
	    printf("No\n");
	    return ;
	 }
     }
     printf("Yes\n");
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){
    	int a,b;
    	scanf("%d%d",&a,&b);
    	v[a].push_back(i);
    	v[b].push_back(i);
    }
    int k;
    scanf("%d",&k);
    while(k--){
    	int Nv;
    	scanf("%d",&Nv);
    	for(int i=1;i<=m;i++) vis[i]=false;
    	while(Nv--){
    	    int x;
    	    scanf("%d",&x);
    	    for(int i=0;i<v[x].size();i++){
    		vis[v[x][i]]=true;
	    }
	}
	judge(m);
    }
    return 0;
}
发布了415 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/103244366