【笨方法学PAT】1134 Vertex Cover (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84616039

一、题目

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

二、题目大意

每条边至少有一个顶点出现在集合中。

三、考点

SET

四、注意

1、读懂题目。

五、代码

#include<iostream>
#include<vector>
#include<set>
#define N 10001
using namespace std;
bool e[N][N] = { false };

int main() {
	//read
	int n, m;
	cin >> n >> m;
	vector<vector<int>> v(m);
	for (int i = 0; i < m; ++i) {
		int a, b;
		cin >> a >> b;
		v[i].push_back(a);
		v[i].push_back(b);
	}

	//query
	int l;
	cin >> l;
	while(l--) {
		//read
		int k;
		cin >> k;
		set<int> sset;
		for (int i = 0; i < k; ++i) {
			int a;
			cin >> a;
			sset.insert(a);
		}

		//judge
		bool flag = true;
		for (int i = 0; i < m; ++i) {
			//not find
			if (sset.find(v[i][0]) == sset.end() && sset.find(v[i][1]) == sset.end()) {
				flag = false;
				break;
			}
		}

		//output
		if (flag == true)
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84616039