PAT(A) 1134. Vertex Cover (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79542800

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1134

1134. Vertex Cover (25)


A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] … v[Nv]

where Nv is the number of vertices in the set, and v[i]’s are the indices of the vertices.

Output Specification:

For each query, print in a line “Yes” if the set is a vertex cover, or “No” if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No

题目大意

对于一个图,如果有一个集合,使得图中的任意一条边都至少存在一个端点在这个集合中,这个集合便可以为vertex cover。
输入图信息,N,M表示N个点M个边,依次输入M个边。
后K个集合,判断是否为vertex cover。

解题报告

先把边存起来,然后对于每个集合,遍历所有的边进行判断。

代码

/*
* Problem: 1134. Vertex Cover (25)
* Author: HQ
* Time: 2018-03-13
* State: Done
* Memo: set
*/
#include "iostream"
#include "set"
#include "vector"
using namespace std;

struct Node {
    int b;
    int e;
};

int N, M, K;
set<int> v;
vector<struct Node> edges;

int main() {
    scanf("%d %d",&N, &M);
    int x,y;
    for (int i = 0; i < M; i++) {
        scanf("%d %d", &x, &y);
        struct Node temp = { x,y };
        edges.push_back(temp);
    }
    int n;
    scanf("%d", &K);
    for (int i = 0; i < K; i++) {
        scanf("%d", &n);
        v.clear();
        for (int j = 0; j < n; j++) {
            scanf("%d", &x);
            v.insert(x);
        }
        bool flag = true;
        for (int j = 0; j < M; j++) {
            if (v.find(edges[j].b) == v.end() && v.find(edges[j].e) == v.end()) {
                flag = false;
                break;
            }
        }
        if (flag)
            cout << "Yes" << endl;
        else
            cout << "No" << endl;
    }

    system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79542800