PAT甲级 1134 Vertex Cover (25 分)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.

After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2] … v[Nv]

where Nv is the number of vertices in the set, and v[i]’s are the indices of the vertices.

Output Specification:

For each query, print in a line “Yes” if the set is a vertex cover, or “No” if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
Sample Output:
No
Yes
Yes
No
No


题目大意
A vertex cover是一个点集,对于图的每一条边都接入这个点集中。
每次询问求给定的集合是否为vertex cover

分析
输入时记录一下边,询问时遍历一下边即可

错误记录
遍历边时for (int i = 0; i < m; i ++) 错写成了for (int i = 0; i < n; i ++)

#include <bits/stdc++.h>
using namespace std;
int n, m;
const int maxn = 10010;
vector<int> v[maxn];
bool vis[maxn];

bool judge()
{
    int num, u;
    cin >> num;
    for (int i = 0; i < num; i ++)
    {
        cin >> u;
        for (auto x : v[u]) vis[x] = 1;
    }
    for (int i = 0; i < m; i ++)
        if (!vis[i]) return false;
    return true;
}

int main()
{
	int a, b, k;
    cin >> n >> m;
    for (int i = 0; i < m; i ++)
    {
        cin >> a >> b;
        v[a].push_back(i);
        v[b].push_back(i);
    }

    cin >> k;
    while (k --)
    {   
    	memset(vis, 0, sizeof vis);
        judge()?puts("Yes"):puts("No");
    }
    return 0;
}
发布了673 篇原创文章 · 获赞 644 · 访问量 38万+

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/90371166