1134 Vertex Cover(25 分)

1134 Vertex Cover(25 分)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

讲真 我看不懂题意是搜博客才看懂题目意思的

题目意思是 em...给出n个节点和m条边  对应输入

然后判断一下输入的集合是否能够覆盖每一条边  意思就是 比如1 4 8 这三个数字要覆盖那m条边的点  即每条边都至少有一个节点是{1,4,8}

代码:

#include<bits/stdc++.h> 
using namespace std;
const int maxn = 1e4+10;
int dd[maxn];
map<int,vector<int> >mp;
int main()
{
	int n,m,x,y;
	scanf("%d%d", &n, &m);
	for(int i = 1; i <= m ;i ++)
	{
		scanf("%d%d",&x, &y);
		mp[x].push_back(i);
		mp[y].push_back(i);	
	}
	int k,num;
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d",&num);
		set<int>st;
		for(int i = 1; i <= num;i++)
		{
			scanf("%d",&dd[i]);
			for(int j = 0 ; j < mp[dd[i]].size();j++)
				st.insert(mp[dd[i]][j]);
		}	
		if(st.size() == m)
			printf("Yes\n");
		else 
			printf("No\n");			
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/81632880