#1134. Vertex Cover【图论 + 模拟】

原题链接

Problem Description:

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N N N and M M M (both no more than 1 0 4 10^4 104), being the total numbers of vertices and the edges, respectively. Then M M M lines follow, each describes an edge by giving the indices (from 0 to N − 1 N−1 N1) of the two ends of the edge.

After the graph, a positive integer K K K ( ≤ 100 \leq 100 100) is given, which is the number of queries. Then K K K lines of queries follow, each in the format:

N v N_v Nv v [ 1 ] v[1] v[1] v [ 2 ] v[2] v[2] ⋯ \cdots v [ N v ] v[N_v] v[Nv]

where N v N_v Nv is the number of vertices in the set, and v [ i ] v[i] v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

Problem Analysis:

图论模拟问题,由于不需要遍历图,可以用结构体存边,然后开 bool 数组标记点,对于每组询问,直接遍历所有边进行判断即可。

Code

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 10010;

int n, m;
struct Edge
{
    
    
    int a, b;
}e[N];
bool st[N];

int main()
{
    
       
    cin >> n >> m;
    for (int i = 0; i < m; i ++ ) cin >> e[i].a >> e[i].b;

    int k;
    cin >> k;
    while (k -- )
    {
    
    
        int cnt;
        cin >> cnt;
        
        memset(st, 0, sizeof st);
        while (cnt -- )
        {
    
    
            int x;
            cin >> x;
            st[x] = true;
        }

        int i;
        for (i = 0; i < m; i ++ )
            if (!st[e[i].a] && !st[e[i].b])
                break;
        if (i == m) puts("Yes");
        else puts("No");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121060738