【PAT】A1134 Vertex Cover (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 600 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1134 Vertex Cover (25point(s))

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4​​ ), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​ ]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

Code

#include <bits/stdc++.h>
using namespace std;
vector<vector<int>> near(10000);
vector<int> degree(10000),degreeT(10000);
int main(){
    int n,nv,m,k,u,v;
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>u>>v;
        near[u].push_back(v);
        near[v].push_back(u);
        degreeT[u]++;
        degreeT[v]++;
    }
    cin>>k;
    for(int i=0;i<k;i++){
        degree=degreeT;
        int flag=0;
        cin>>nv;
        for(int j=0;j<nv;j++){
            cin>>u;
            for(int l=0;l<near[u].size();l++){
                degree[u]--;
                degree[near[u][l]]--;
            }
        }
        for(int j=0;j<n;j++){
            if(degree[j]>0){
                flag=1;
                break;
            }
        }
        if(flag==1) printf("No\n");
        else    printf("Yes\n");
    }
    return 0;
}

Analysis

-已知一张图的连通情况,判断给定的一个顶点集合是不是连接着图中所有的边。

-首先求出这张图每一个顶点的度,对于每一个顶点集合,没找到一个点,就把它和与它相连的顶点的度各减减。然后遍历所有顶点,如果此时还有顶点的度大于0,说明这个集合不符合题目要求。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103901849