PAT (Advanced Level) Practice 1134 Vertex Cover(25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Puppettt/article/details/82144574

1134 Vertex Cover(25 分)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

题意:问是否图中的每条边与询问的点有关联。

思路:记录每条边的两个点,判断是否该点被询问。

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e4+5;
int vis[maxn]={0};
int vv[maxn]={0};
vector<int >v[maxn];
struct node{
    int a,b;
}lin[maxn];
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int a,b;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d",&a,&b);
        lin[i].a=a;
        lin[i].b=b;
    }
    int q;scanf("%d",&q);
    while(q--)
    {
        int k;
        memset(vv,0,sizeof(vv));
        scanf("%d",&k);
        int flag=1;
        //set <int>ask;
        for(int i=0;i<k;i++)
        {
            scanf("%d",&a);
            vv[a]=1;
        }
        for(int i=0;i<m;i++)
        {
            a=lin[i].a;
            b=lin[i].b;

            if(vv[a]||vv[b])continue;
            else {
                flag=0;break;
            }
        }
        if(flag)printf("Yes\n");
        else printf("No\n");
    }
}
扫描二维码关注公众号,回复: 3011085 查看本文章

猜你喜欢

转载自blog.csdn.net/Puppettt/article/details/82144574