1134 Vertex Cover (25 分)(hash散列)

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10

4

), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N

v

v[1] v[2]…v[N

v

]

where N

v

is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11

8 7

6 8

4 5

8 4

8 1

1 2

1 4

9 8

9 1

1 0

2 4

5

4 0 3 8 4

6 6 1 7 5 4 9

3 1 8 4

2 2 8

7 9 8 7 6 5 4 2

Sample Output:

No

Yes

Yes

No

No

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
int main() {
    int n,m,a,b,k,nv,num;
    cin>>n>>m;
    vector<int> v[n];
    for(int i=0;i<m;i++){
        cin>>a>>b;
        v[a].push_back(i);
        v[b].push_back(i);
    }
    cin>>k;
    for(int i=0;i<k;i++){
        cin>>nv;
        int flag=0;
        vector<int> hash(m,0);
        for(int j=0;j<nv;j++){
            cin>>num;
            for(int t=0;t<v[num].size();t++)
                hash[v[num][t]]=1;
        }
        for(int j=0;j<m;j++){
            if(hash[j]==0){
                cout<<"No\n";
                flag=1;
                break;
            }
        }
        if(flag==0) cout<<"Yes\n";
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/87978460