1134 Vertex Cover(25 分)(C++)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

图论:给定一个图,再给定一个节点集合,判断这些节点能否包含所有的边。

hash思想:给每条edge标号。

#include <vector>
#include <iostream>
using namespace std;
bool visit[10010];
int main(){
    int v,e,k;
    scanf("%d %d",&v,&e);
    std::vector<int> graph[10010];
    for(int i=0;i<e;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        graph[a].push_back(i);
        graph[b].push_back(i);
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        int tempnum,temp,num=0;
        scanf("%d",&tempnum);
        fill(visit,visit+10010,false);
        for(int j=0;j<tempnum;j++){
            scanf("%d",&temp);
            for(int u=0;u<graph[temp].size();u++){
                if(visit[graph[temp][u]]==false){
                    num++;
                    visit[graph[temp][u]]=true;
                }
            }
        }
        if(num==e)
                printf("Yes\n");
        else
                printf("No\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82526107