HDU1711-Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

题意:原序列,找子序列在原序列中的位置,字符串的匹配问题 

思路:KMP算法

#include <stdio.h>
int a[1000000+5];
int b[10000+5];
int next[10000+5];
int n,m;
void setnext(){
    int i=-1;
    int j=0;
    next[0]=-1;
    while(j<m){
        if(i==-1||a[i]==b[j]){
            i++;
            j++;
            next[j]=i;
        }
        else{
            i=next[i];
        }
    }
}
int kmp(){
    int res=-1;
    setnext();
    int i=0,j=0;
    while(i<n){
        if(j==-1||a[i]==b[j]){
            i++;
            j++;
        }
        else{
            j=next[j];
        }
        if(j==m){
            res=i;
            break;
        }
    }
    if(res==-1)
    return -1;
    else
    return res-m+1;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(int j=0;j<m;j++){
            scanf("%d",&b[j]);
        }
        printf("%d\n",kmp());
    }
}
发布了73 篇原创文章 · 获赞 27 · 访问量 1228

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103846010