1007 Maximum Subsequence Sum

Given a sequence of K integers { N~1~, N~2~, …, N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, …, N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4

题目大意:给定一系列数字,求和最大的一段子序列,输出起始序列的元素。

分析:应用贪心算法,每次都要最好的。假设sum和temp_sum,新输入一个元素num下标为i,temp_sum=temp_sum+num。如果temp_sum<0,应该舍掉,因为与后面的数字相加,只会是那个数字更小,所以temp_sum重置为0,潜在的序列的开始下标至少为i+1。如果temp_sum>sum,则sum=temp_sum,begin=temp_begin,end=i;

参考代码:

#include<iostream>
#include<vector>

using namespace std;

int main()
{
    int n, num, begin = 0, end, sum = -1;
    int temp_begin = 0, temp_sum = 0;
    bool flag = true;
    cin >> n;
    end = n - 1;
    vector<int>v(n);
    for (int i = 0; i < n; i++)
    {
        cin >> num;
        if (num >= 0)flag = false;
        v[i] = num;
        temp_sum += num;
        if (temp_sum < 0)
        {
            temp_sum = 0;
            temp_begin = i + 1;
        }
        else if (temp_sum > sum)
        {
            begin = temp_begin;
            end = i;
            sum = temp_sum;
        }
    }
    if (flag)
        cout << "0 " << v[0] << " " << v[n - 1];
    else
    {
        cout << sum << " " << v[begin] << " " << v[end];
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81411212