1007 Maximum Subsequence Sum (25 分)

1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目中要求求解和最大的连续子序列,并且如果序列中所有数字都为负数,则和为0,然后输出子序列的和以及子序列区间左边节点右边节点位置上的数字

直接使用前缀和解决即可,当前缀和小于0时,直接将前缀和置为0,然后重新标记左边节点位置,因为前缀和已经为0了,那么加上前面已经会使后面越来越小,如果存在比当前最大值大的数值,则更新最大数值,左边节点,右边节点。

当我们求解出最大子序列和为ans初值-1时,我们即可确定序列中所有数字都为负数

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <cmath>
#define INF 0x3f3f3f3f

using namespace std;
typedef long long ll;
const int mod = 1e9+7;
const int maxn = 1e4+1000;
int n,a[maxn];
int temp;

int main()
{
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",a+i);

    int _min_pos = 0,left_pos = 0,right_pos = 0,ans = -1;
   temp = 0;
    for(int i = 0;i < n;i ++)
    {
        temp += a[i];
        if(temp < 0)
            temp = 0 ,_min_pos = i+1;
        else if(temp  > ans)
            ans = temp,right_pos = i,left_pos = _min_pos;
    }
    if(ans < 0)
        printf("0 %d %d\n",a[0],a[n-1]);
    else
        printf("%d %d %d\n",ans,a[left_pos],a[right_pos]);

}

参考博客

https://blog.csdn.net/liuchuo/article/details/52144554 

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84454067