hdu 1232 畅通工程

畅通工程
Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63628    Accepted Submission(s): 34062


Problem Description
  某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
  测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
  注意:两个城市之间可以有多条道路相通,也就是说
  3 3
  1 2
  1 2
  2 1
  这种输入也是合法的
  当N为0时,输入结束,该用例不被处理。
 

Output
  对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
  4 2
  1 3
  4 3
  3 3
  1 2
  1 3
  2 3
  5 2
  1 2
  3 5
  999 0
  0

Sample Output
  1
  0
  2
  998

 Hint
 
  Huge input, scanf is recommended.

  

/**
    分析:
        1、这道题其实就是求有多少个不连通区域(n);
        2、n - 1 表示的就是将 n 个城市连接起来需要的最少路线;
        3、处理连通区域问题用并查集;

    并查集模板:
        ①、pre [] 数组   <==>  用于存一个点的前驱节点

        ②、my_find() 函数   <==>   用于查找根节点

        int my_find (int x)
        {
            int r = x;
            while (r != pre [r])
                r = pre [r];
            int i = x, j;
            while (pre [i] != r) // 路径压缩 p[x] --> r 的路径上的元素全部直接指向根节点r
            {
                j = pre [i];
                pre [i] = r;
                i = j;
            }
            return r;
        }

        ③、join() 函数   <==>  用于将不在同一个连通区域的点连通

        void join (int a, int b)
        {
            int n1 = my_find (a), n2 = my_find (b);
            if (n1 != n2)
                pre [n1] = n2;
        }
**/

C/C++代码实现:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>

using namespace std;

int n, m, a, b, pre [1005];

void init_pre ()
{
    for (int i = 1; i <= n; ++i)
        pre [i] = i;
    return ;
}

int my_find (int x)
{
    int r = x;
    while (r != pre [r])
        r = pre [r];
    int i = x, j;
    while (pre [i] != r)
    {
        j = pre [i];
        pre [i] = r;
        i = j;
    }
    return r;
}

void join ()
{
    int n1 = my_find (a), n2 = my_find (b);
    if (n1 != n2)
        pre [n1] = n2;
    return ;
}

int main () {
    while (scanf ("%d", &n), n)
    {
        scanf ("%d", &m);
        init_pre ();
        for (int i = 0; i < m; ++ i)
        {
            scanf ("%d%d", &a, &b);
            join ();
        }

        int temp = 0;
        for (int i = 1; i <= n; ++i)
        {
            if (pre [i] == i)
                ++ temp;
        }
        printf ("%d\n", temp - 1);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/GetcharZp/p/8934942.html
今日推荐