HDU 1232畅通工程【并查集】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/81986997

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说 
3 3 
1 2 
1 2 
2 1 
这种输入也是合法的 
当N为0时,输入结束,该用例不被处理。 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。 

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output

1
0
2
998

题解:如果两个城镇已经可以相互到达,则不需要增加路,否则需要增加一条路将这两个城市连通。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int maxn=1005;
int pre[maxn];
int n,m;
void init(){
	for(int i=1;i<=n;i++)
		pre[i]=-1;
}
int Find(int x) {
	int r=x;
	while(pre[r]!=-1){
		r=pre[r];
	}
	while(r!=x){
		int t=pre[x];
		pre[x]=r;
		x=t;
	}
	return r;
}
void Merge(int x,int y){
	int fx=Find(x);
	int fy=Find(y);
	if(fx!=fy){
		pre[fx]=fy;
	}
}
int main(){
	int a,b;
	while(scanf("%d",&n)&&n){
		init();
		int cnt=1;
		scanf("%d",&m);
		while(m--){
			scanf("%d %d",&a,&b);
			if(Find(a)!=Find(b)){
				Merge(a,b);
				cnt++;
			}
		}
		printf("%d\n",n-cnt);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/81986997