Bomb 数位DP HDU

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 26039 Accepted Submission(s): 9876

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

数位DP和DFS的综合 优化数数的方法
不超过5123

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int dig[20];
LL dp[20][2];
LL dfs(int len, bool if4, bool limit)
{
    if(len == 0)
        return 1;
    if(!limit && dp[len][if4]) // 记录状态 
        return dp[len][if4];
    LL cnt = 0, up_bound = (limit ? dig[len]:9);
    for(int  i = 0; i <= up_bound; ++i)
    {
        if(if4 && i == 9)
            continue;
        cnt += dfs(len - 1, i == 4, limit && i == up_bound);

    }
    if(!limit)
        dp[len][if4] = cnt;
    return cnt;
}
LL solve(LL num)
{
    int k = 0;//记录数位
    while(num)
    {
        dig[++k] = num %10;
        num /= 10;
    }
    return dfs(k,false,true);
}
int main()
{
    int t;
    LL n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        printf("%lld\n",n+1-solve(n));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/king9666/article/details/89810472
今日推荐