HDU-3555 Bomb (数位dp)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/86376715

Bomb

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15


        
  

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
        

题目大意: 区间 [1,n] 中 含49 的数的个数 

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
int d[20];
ll dp[20][2];
ll dfs(int len,int if4,int lim)
{
    if(len==0) return 1;
    if(!lim&&dp[len][if4]!=-1) return dp[len][if4];
    int maxx=lim?d[len]:9;
    ll cnt=0;
    for(int i=0;i<=maxx;i++)
    {
        if(if4&&i==9) continue;
        cnt+=dfs(len-1,i==4,lim&&i==maxx);
    }
    if(!lim) dp[len][if4]=cnt;
    return cnt;
}
ll solve(ll n)
{
    int len=0;
    while(n)
    {
        d[++len]=n%10;
        n/=10;
    }
    return dfs(len,0,1);
}
int main()
{
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        ll n;
        scanf("%lld",&n);
        printf("%lld\n",n+1-solve(n));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/86376715