HDU - 3555 Bomb (数位dp入门题)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15

求比m小的含“49”子串的数字的个数。
数位dp入门题。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<math.h>
#include<vector>
#include<stack>
#include<string>
#include<set>
#include<map>
#include<numeric>
#include<stdio.h>
#include<functional>
#include<time.h>
#pragma warning(disable:6031)

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1010;
const ll mode = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const double pi = 3.14159265358979323846264338327950;
template <class T> inline T min(T a, T b, T c) { return min(min(a, b), c); }
template <class T> inline T max(T a, T b, T c) { return max(max(a, b), c); }
template <class T> inline T min(T a, T b, T c, T d) { return min(min(a, b), min(c, d)); }
template <class T> inline T max(T a, T b, T c, T d) { return max(max(a, b), max(c, d)); }


ll dp[15][3];

//dp[i][0]  合法数 
//dp[i][1]  9开头的合法数 
//dp[i][2]  含49的非法数 

void init(void) 
{
	memset(dp, 0, sizeof(dp));
	dp[0][0] = 1;
	int i;
	for (i = 1; i < 15; i++)
	{
		dp[i][0] = dp[i - 1][0] * 10 - dp[i - 1][1];
		dp[i][1] = dp[i - 1][0];
		dp[i][2] = dp[i - 1][2] * 10 + dp[i - 1][1];
	}
}

ll solve(ll x)
{
	int len = 0, digit[21];
	while (x) 
	{
		digit[++len] = x % 10;
		x /= 10;
	}
	digit[len + 1] = 0;
	int i;
	ll ans = 0;
	bool flag = false;
	for (i = len; i > 0; i--) 
	{
		ans += digit[i] * dp[i - 1][2];
		if (flag)
			ans += dp[i - 1][0] * digit[i];
		if (!flag && digit[i] > 4)
			ans += dp[i - 1][1];
		if (digit[i + 1] == 4 && digit[i] == 9)
			flag = true;
	}
	return ans;
}

int main()
{
	init();
	int T;
	scanf("%d", &T);
	while (T--) 
	{
		ll n;
		scanf("%lld", &n);
		printf("%lld\n", solve(n + 1));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43896680/article/details/86665144