hdu3555Bomb(数位dp)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sdz20172133/article/details/82531876

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

 

3 1 50 500

Sample Output

 

0 1 15


要49

可以参考这个题:点这里

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[20];
ll dp[25][3];
ll dfs(int pos,int sta,bool limit)

{
    if(pos==-1) return sta==2;
    if(!limit && dp[pos][sta]!=-1) return dp[pos][sta];
    int up=limit ? a[pos] : 9;
	ll tmp=0;
    for(int i=0;i<=up;i++)
    {
   
    	int tsta=sta;  
    	 if(sta==0&&i==4)
    	 	tsta=1;
		 else if(sta==1&&i!=4&&i!=9)
		 	tsta=0;
		 else if(sta==1&&i==9)
		 	tsta=2;
        tmp+=dfs(pos-1,tsta,limit && i==a[pos]);
    }
    if(!limit) dp[pos][sta]=tmp;
    return tmp;
}
ll solve(ll x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x%10;
        x/=10;
    }
   
    return dfs(pos-1,0,true);
}
int main()
{
                        
    ll n;
	memset(dp,-1,sizeof dp);
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%lld",&n); 
  
        printf("%lld\n",solve(n));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/82531876