【HDU 3555】Bomb(数位dp)

Bomb
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 23401 Accepted Submission(s): 8811

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,”149”,”249”,”349”,”449”,”490”,”491”,”492”,”493”,”494”,”495”,”496”,”497”,”498”,”499”,
so the answer is 15.

Author
fatboy_cw@WHU

Source
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

研究了好久的数位dp,现在基本上入门了,什么是数位dp,数位dp就是在数位上面进行的动态规划,一般情况下都是利用DFS+记忆化来进行状态转移的
我们在DFS的时候一般会传递三个变量:pos(位置),sta(状态),limit(是否达到上限)。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
const int INF = 0x3f3f3f3f;
typedef int INT;
#define int long long
int digit[200];
int dp[30][2];
int dfs(int pos,bool if4,bool limit){
    if(pos==0) return 1;
    if(!limit&&dp[pos][if4]) return dp[pos][if4];

    int ans=0;
    int up=(limit?digit[pos]:9);

    for(int i=0;i<=up;i++){
        if(if4&&i==9) continue;
        ans+=dfs(pos-1,i==4,limit&&i==up);
    }
    if(!limit) dp[pos][if4]=ans;
    return ans;
}

int solve(int x){
    int cnt=0;
    while(x){
        digit[++cnt]=x%10;
        x/=10;
    }
    return dfs(cnt,0,1);
} 
INT main(){
    int t,n;
    cin>>t;
    while(t--){
        cin>>n;
        cout<<n-solve(n)+1<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/82628846