【HDU】3555Bomb-数位dp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 23337    Accepted Submission(s): 8785


 

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

Output

For each test case, output an integer indicating the final points of the power.

 

Sample Input

 

3 1 50 500

 

Sample Output

 
0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.  

Author

fatboy_cw@WHU

 

Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

 

Recommend

zhouzeyong   |   We have carefully selected several similar problems for you:  3554 3556 3557 3558 3559 

题目大意:给出t组数据,每组数据为n,问从0~n中不包含49的数字,不连着的不算,比如409,这样的是不算的,

思路:这个的话,与不要62特别相似的题目了,

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define ll long long
using namespace std;

ll n;
int t,a[25];
ll dp[25][2];

ll dfs(int pos,bool sta,bool limit)
{
    if(pos==-1)
        return 1;
    if(!limit&&dp[pos][sta]!=-1)
        return dp[pos][sta];

	int up=limit ? a[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        if(sta&&i==9)
            continue;
        ans+=dfs(pos-1,i==4,limit&&i==up);
    }
    if(!limit) dp[pos][sta]=ans;
    return ans;
}

void work(ll n)
{
    memset(a,0,sizeof(a));
    memset(dp,-1,sizeof(dp));
    int pos=0;
    ll m=n;
    while(n)
    {
        a[pos++]=n%10;
        n/=10;
    }

	printf("%lld\n",m-(dfs(pos-1,false,true)-1));
}
int main()
{
    cin>>t;
    while(t--)
    {

        cin>>n;
        work(n);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/82505533